View Issue Details

IDProjectCategoryView StatusLast Update
0027573mantisbtcode cleanuppublic2020-11-21 19:27
Reporterdregad Assigned Todregad  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Target Version2.25.0Fixed in Version2.25.0 
Summary0027573: PHP notice in manage_user_edit_page.php when given invalid user id
Description

I guess this is not a normal usage scenario, but calling manage_user_edit_page.php with an invalid user_id causes PHP to throw a system notice Trying to access array offset on value of type bool, because the code does not check user_get_row()'s return value, which is false when the id does not exist.

TagsNo tags attached.

Activities

There are no notes attached to this issue.

Related Changesets

MantisBT: master ac22c041

2020-11-21 18:17:37

dregad

Details Diff
Handle invalid user id

Failure to check user_get_row()'s return value results in system notice
'Trying to access array offset on value of type bool' when an invalid
user_id parameter is given to manage_user_edit_page.php.

Fixes 0027573
Affected Issues
0027573
mod - manage_user_edit_page.php Diff File

Issue History

Date Modified Username Field Change
2020-11-21 18:38 dregad New Issue
2020-11-21 18:38 dregad Status new => assigned
2020-11-21 18:38 dregad Assigned To => dregad
2020-11-21 19:27 dregad Changeset attached => MantisBT master ac22c041
2020-11-21 19:27 dregad Status assigned => resolved
2020-11-21 19:27 dregad Resolution open => fixed
2020-11-21 19:27 dregad Fixed in Version => 2.25.0