Unable to upload attachments in edit mode

Get help from other users here.

Moderators: Developer, Contributor

manokugan
Posts: 12
Joined: 22 May 2017, 10:19

Unable to upload attachments in edit mode

Post by manokugan »

I m using Mantis 2.4.0, and when creating issue i m able to upload files, but when I edit the issue, I m unable to upload new attachments. The upload attachment field itself is missing. I have added the screenshot below. Please help me
mantisussue.png
mantisussue.png (35.06 KiB) Viewed 17424 times
atrol
Site Admin
Posts: 8273
Joined: 26 Mar 2008, 21:37
Location: Germany

Re: Unable to upload attachments in edit mode

Post by atrol »

Attachments can just be added to an issue using the "View Issue Details" page.
Please use Search before posting and read the Manual
Knubbi
Posts: 22
Joined: 14 May 2017, 14:35

Re: Unable to upload attachments in edit mode

Post by Knubbi »

The upload feature is also sorely missing when reopening a ticket ("feedback") in the add note section,

We often need to add screenshots to feedback notes.
atrol
Site Admin
Posts: 8273
Joined: 26 Mar 2008, 21:37
Location: Germany

Re: Unable to upload attachments in edit mode

Post by atrol »

Both are known feature requests where no core developer or community member is assigned at the moment.
https://www.mantisbt.org/bugs/view.php?id=21819
https://www.mantisbt.org/bugs/view.php?id=21820
So don't expect that it will available in short term, but who knows ...

@Knubbi or @manokugan maybe you want to work on this issue?
Please use Search before posting and read the Manual
manokugan
Posts: 12
Joined: 22 May 2017, 10:19

Re: Unable to upload attachments in edit mode

Post by manokugan »

atrol wrote:Attachments can just be added to an issue using the "View Issue Details" page.

I dont see Attach field available in view issues page either. Please refer the screenshot for more details. But I guess with the issues you have mentioned this is not available in view issue details page also.
mantisussue.png
mantisussue.png (80.94 KiB) Viewed 17412 times
atrol
Site Admin
Posts: 8273
Joined: 26 Mar 2008, 21:37
Location: Germany

Re: Unable to upload attachments in edit mode

Post by atrol »

manokugan wrote:I dont see Attach field available in view issues page either.
I am quite sure this is caused by changed configuration and/or installed 3rd party plugins.
manokugan wrote:But I guess with the issues you have mentioned this is not available in view issue details page also.
It's certainly available, e.g. create an account at https://www.mantisbt.org/bugs to see that there is a field "Upload Files" in section "Add Note"
Please use Search before posting and read the Manual
manokugan
Posts: 12
Joined: 22 May 2017, 10:19

Re: Unable to upload attachments in edit mode

Post by manokugan »

Yea I checked it and its available, any idea what could be the problem in my installation ( These are the plugins I ve installed : Import/Export issues 2.4.0,Mantis Graphs 2.4.0,MantisBT Core 2.4.0,MantisBT Formatting 2.4.0, MantisStats 2.4.0)
atrol wrote:
manokugan wrote:I dont see Attach field available in view issues page either.
I am quite sure this is caused by changed configuration and/or installed 3rd party plugins.
manokugan wrote:But I guess with the issues you have mentioned this is not available in view issue details page also.
It's certainly available, e.g. create an account at https://www.mantisbt.org/bugs to see that there is a field "Upload Files" in section "Add Note"
atrol
Site Admin
Posts: 8273
Joined: 26 Mar 2008, 21:37
Location: Germany

Re: Unable to upload attachments in edit mode

Post by atrol »

As a first step I would try to uninstall MantisStats 2.4.0 as this is a 3rd party plugin.

All other plugins are part of Mantis Core and delivered with Mantis.
I am not aware that any of those plugins causes such an issue.
Please use Search before posting and read the Manual
manokugan
Posts: 12
Joined: 22 May 2017, 10:19

Re: Unable to upload attachments in edit mode

Post by manokugan »

I found the issue, when the "private' check box is checked in Add Notes the attachment option goes hidden, but when it is unchecked the option is available. Thanks for your time
atrol wrote:As a first step I would try to uninstall MantisStats 2.4.0 as this is a 3rd party plugin.

All other plugins are part of Mantis Core and delivered with Mantis.
I am not aware that any of those plugins causes such an issue.
atrol
Site Admin
Posts: 8273
Joined: 26 Mar 2008, 21:37
Location: Germany

Re: Unable to upload attachments in edit mode

Post by atrol »

manokugan wrote:I found the issue, when the "private' check box is checked in Add Notes the attachment option goes hidden,
That explains it, I really should have taken a closer look at your screen shot.
We have to do it this way, as we don't support private attachments at the moment, see https://www.mantisbt.org/bugs/view.php?id=9802
Please use Search before posting and read the Manual
garyccy
Posts: 1
Joined: 19 Jul 2018, 08:44

Re: Unable to upload attachments in edit mode

Post by garyccy »

Those related tickets were submitted in Oct 2016,
https://www.mantisbt.org/bugs/view.php?id=21819
https://www.mantisbt.org/bugs/view.php?id=21820
these tickets were set as "Closed", but this function (upload/update attachments in edit mode) seems still not available?

It will be really useful if we can manage attachment after a note was submitted, both Add and Remove. For example, if you submitted a note with a wrong attachment, you have to Delete the note, submit a new one and attach the correct file. The problem is, this new note is at the end of the list, not at the original note's position, making the conversation history looks awkward.
atrol
Site Admin
Posts: 8273
Joined: 26 Mar 2008, 21:37
Location: Germany

Re: Unable to upload attachments in edit mode

Post by atrol »

garyccy wrote: 19 Jul 2018, 09:08 these tickets were set as "Closed"
Closed? Status of #21819 is "acknowledged" and status of #21820 is "new".

So yes, the function is not available.
Please use Search before posting and read the Manual
argniest
Posts: 9
Joined: 19 Jul 2018, 17:31

Re: Unable to upload attachments in edit mode

Post by argniest »

I have been reading up on some issues in this forum, and trying to understand what limits there are on the current upload attachments in Mantis BT

So far, I have only been able to upload attachments when I first create the issue. I did get that working (after tweaking a php extension setting and of course setting up the mantis config file settings for file uploads)

Can you tell me if I am supposed to be able to go into an existing issue,
1. and upload a new file attachment?
2. delete an existing file attachment?

I just never see anyway to do that, after I initially upload the file when I am creating the issue.

I am uploading files to DISK and not DATABASE - per my settings in the config file.

THANKS!
argniest
Posts: 9
Joined: 19 Jul 2018, 17:31

Re: Unable to upload attachments in edit mode

Post by argniest »

I just realized something else....after looking at the Add Notes section of the issue screen. I see that if I add a new note and ALSO upload or drag and drop a new file....well...(and then you click the add note button) it uploads another picture. For some reason I didnt realize that until now.

Although it had me wondering a little bit about how the File attach looked to be inside of the Notes portion of the screen.

I am very glad this is possible. And it makes sense now that I realized it can be done this way.

I was thinking the file attachment was kind of a standalone thing, and not linked to 'adding a note'

So I guess I just answered my own question. ;-) whooops
mynameispaulie
Posts: 2
Joined: 20 Jan 2020, 14:45

Re: Unable to upload attachments in edit mode

Post by mynameispaulie »

I had this same issue and I too eventually realized that I could drag files to the Add Note text box, and the file would get uploaded when hitting 'Add Note'. However, it wasn't ideal not having any confirmation of the file upload and certainly is not at all intuitive to my users.

I later found that changing $g_default_bugnote_view_status back to VS_PUBLIC caused the Upload File section inside Add Note to return. It seems attachments cannot be PRIVATE so trying to force them to be so makes the Upload File section go away.
Post Reply